BUG REPORTS: Connection loss and F & P bug (also EAC kick)

BUG REPORTS: Connection loss and F & P bug (also EAC kick)

Dear friends,

many of us have the trouble of loosing the connection (visible due to F and P keys not working and you cant chat anymore) and sometimes also EAC kicks afterwards.

This bug is crazy and keeps some players from playing at all. Similar to the crazy EAC kicks which we also have to find. They seem to be connected.
Therefore we want to organize the whole thing a bit more so that we can nail it down.

This thread is especially for those, who encounter the problem often. If you can, please report every or as many situations as possible. If you have one situation again and again, maybe just add/edit infos to your last one, (if you noticed something different). If they are exactly the same, just add another time/playfield info into that post instead of creating a new one.

If you encounter the bug, please post here some information in the following way (if there are sensitive information, please pm us the full report instead and leave the sensitive information out here):

TEMPLATE


Server:
Server Time: (cb:time)
Playfield:
Structure: (which structure you were in, close to [Name or ID])
Action: (Please describe what you were doing at that moment and also the last 5 minutes if you did not use F or P for longer and just noticed)
Surrounding: (Anything special in the surroundings. Animals, Asteorides, other people, A lot of structures…, Hoover drills )
Other wired stuff I noticed: (anything else that was strange beside the F and P or Chat bug; Please if possible send a screenshot)
EAC Kick: Yes/No
Server load: (was the server full or empty)
Ping: (See Server list)
FPS:
Client Logs: (upload as Zip)
Console Screenshot: (when you noticed the problem, make a screenshot of the open console.)
Solution: (if you did something to make it stop for some time)
Video: (if you have the problem more often, please make videos!)
Problem since: (Since when do you encounter the problem. Would be important to find out when it started)

What do we want to achive with this…
We want to see

  • how often it happens
  • which players does it affect the most (and how often)
  • is there any relation between those occurences playfield/action/surrounding/structures
  • is it only when server is under high load
  • is EAC allways involved
  • ist there really a clear Solution that works for everyone to fix it for some time. Cause this could give us more clue on why it happens

If you have the problem a lot of times, check chat again and again ot figure out the exact time when you lost the connection… maybe by typing cb:time. That way we can also easily track it.

Thanks a lot for all your help. We hope we can soon find the problem. The devs do their best to help us.
They will make a build soon to send a Messagebox, so that you see when exactly you lost connection.

For example:
Server: EU
Server Time: 25.01.17 10:20 (server time)
Playfield: Zion
Structure: CV: MYTestCV
Action: Last 5 minutes I moved some ammo then hunted a animal and notcide F & P does not work anymore.
Surrounding: My CV and some animals; no other player
Other wired stuff I noticed: My character looked bugged. I could see an Arrrow … (Screenshot attached)
EAC Kick: Yes
Server load: 20 people
Ping: 50
FPS: 53
Client Logs: (upload as Zip)
Console Screenshot:


Solution: no solution
Video: (Link here)
Problem since: 2 Weeks. Maybe with Alpha 9.5

This happened to me on Zion multiple times similar Actions: 25.01.17 10:30; 10:50; 11:22

Hello guys.
I only experienced one disconnect ever, wasn’t a big thing and didn’t even recorded all the data you require. But I’m posting it here because I think it may have a high reproduction success.
Since I died in the process I did not test it any further, but maybe you or devs want to test.
I was at uranus, 10’ish fps due to a base and several ships being nearby. I decided to place a base with a repair block. I thought I would have enough time to place the base and switch the core to faction before the nearby turrets fired at me.
But wrong, I placed the BA starter block, switched it to faction, then some late explosive ammo hit the block and I died to splash damage. Restarted at the nearby CV medbay, but connection was lost. Went to the placed core and cursed my luck because no backpack was there. then found I was not connected/desynched.
Relogged, and I had all the items on me (like if I never died), including the BA starter block. But the core was also placed at the ground too.
I have like 220ms ping to server.

Server: EU
Server Time: 25.01.17 16:10 (server time)
Playfield: Pandora
Structure: CV: ID 6877001
Action: Warped into the system and fly to pandora -> fly over pandora+
Surrounding: My CV and some animals; no other player
Other wired stuff I noticed: ? cant press P or T
EAC Kick: No
Server load: 72 people
Ping: 50
FPS: 60
Client Logs: (upload as Zip)
Console Screenshot:

Logs.zip (44.6 KB)

10:18 Uhr again…

1 Like

General Login Problem (had disconnect while one Guardians moon) - can’t log in ever since:

Server: EU
Server Time: about 2 hours ago
Playfield: Guardian (Moon)
Structure: SV/ motorbike
Action: I was flying with SV over the moon and landed to collect resources. When I left the SV it disapeared and was about 1km away from me. I took out my motorbike and went there - it was directly behind the green wall. I wanted to drive trugh the wall and I couldn’t. I then wanted to relog and can not log in ever since.
Surrounding: just nearly empty moon.
Other wired stuff I noticed: -
EAC Kick: No
Server load: about 70
Ping: cant tell - but usually good
FPS: ok
Client Logs: (upload as Zip)
Console Screenshot: too late :blush:
Solution: -
Video: -
Problem since: about 2h ago from now

I tried it several times until now - it hangs on “Loading game…” screen. But I can connect to other servers!

1 Like

Server: EU
Server Time: 25.01.17 17:35 (server time)
Playfield: Eden
Structure: HV ID 10477004
Action: Mining on Eden
Surrounding: Mining on Eden
Other wired stuff I noticed: ? cant press P or T
EAC Kick: No
Server load: 70 people
Ping: 50
FPS: 60
Console Screenshot:

And 17:56 Uhr again… it makes fun… I delete Empyrion

1 Like

Oh wow DC bug yeah

Time: 19:59 Uhr

Mining with my HV on Eden…

What is that failed setting triangles???

Well i will give my 2 cents here but i believe i have already discovered one of the F P bugs late last night. AND… its reproducable. Sorry i cant stick to the requested format… at work currently, but ill try and send info in later when i get back home…

the short of this… and should be able to be easily duplicated on your side is this…

  1. was in one of many rooms in my CV, opened some cargo boxes and moved all items to inventory . Now inventory is say 60% full…(was only my epic weapon in bottom right corner).

  2. go to second room in CV, open another full or nearly full cargo box (contains more items than i’m sure i had left over slots in inventory for… click the <— button to transfer all items to inventory.

  3. cargo box empties and i though i got lucky they all fit and close cargo box… No EAC kick, was 2am CST so very light load in deep space.

  4. tried open third cargo box just checking stuff and it fails to open… P menu also fails… im in game, no lag, no kick nada… so i relog

  5. come back in game… and im back to the first room … thinking disconnect or wierdness in general (alpha game)… repeat steps 1-3 again and BAMM… same thing… Step 4 happens again.

  6. i did this again and 3 for 3 times it worked every time, failed to open F and P menu

7)last attempt… i MANUALLY clicked items into my inventory until full… noticed there were indeed many more items than i had space fore left over in the cargo boxes

  1. opened F P and F2 buttons are all still working now… issue does not present itself… so thinking this might be a result of the auto moving buttons on inventory / cargo pages…

Hope that helps… sorry i had to log for the night but will try again tonight and let you know the full details if i can… although im sure you can reproduce on your side either way…

2 Likes

I tried that on your ship (sorry mixed the lower Ammo-boxes a bit), but I could not get that problem at all :frowning:

no worries ill check it again and get screens/video and post

Pumpula + Yesterday i have it bug twice. When you take all item from cargo box via button - EAC kick is come. I lost 40k irom ore and 15k magnesium. Don’t use this button. Take item from cargo by clicking.

no problem. I elieve you. I just hoped I myself could also get the error. So far nothing I tried did it. If you can try it again, or we could do it together at the same time that would be nice. I would like to have the error, so that I can help the devs more.
They will put up a Test-Build today again. We let you guys know later when its out.

This topic is no longer a banner. It will no longer appear at the top of every page.

Update on SteamTest available for those who would like to contribute their logs after it happend.

And again…

On Elysium 17:50, I was flying around to loot autominer.

Online Member ca 70

nach 2 min EAC Kick.

Devs should kill EAC!
Or could we test one day without EAC at the server?

I am sorry, did not see this (and the data that I needed to collect) until now, But this bug has been bugging me for over a week now and it is really annoying (that is an understatement btw).

I understand it is hard to trace. I think by now I have been disconnected over 50x in the last week and I still cannot find a pattern to it. It could happen flying, running, opening boxes or autominers, entering or leaving planets, going through the green barrier…

It sometimes happens 10x in 15 minutes and sometimes nothing for hours in a row. It can happen when the server is quiet or busy. And I don’t have any logs. But if it happens again I will make a screenshot. BTW recently I am getting a msg that I have been disconnected (starting yesterday I think, so maybe that has been fixed). I sometimes played for 5-10 mins before I notices I was not connected anymore.

There is one bug that I would specifically like to point out. That is if you move through a barrier (green one or flying in/out of orbit).
This happened to me about 5x (2x orbit, 3x green barrier)
Let me describe my last encounter of this as it is still fresh in my mind (happened yesterday morning, so low traffic on server).

I was doing a run of T3 Autominers (trader starter, EU hard), flying from deposit to deposit to collect resources. Because of bad experience I now check very regularly if I am still connected. So I flew through the green barrier and checked. Still connected. I visited 2 deposits, collected resources and flew to the 3rd. When I got out of my CV it disappeared and I could not access the autominers (got disconnected).

I relogged and found my SV was at the green barrier, the ores that I collected gone from my inventory (and btw from the autominers as well when I checked). I had to run back to the green barrier (about half a planet, not fun). On the way there I think I disconnected at least 5x. You can btw see this looking at your jetpack indicator. If it stops moving while you use it you are disconnected.

When I got to my SV it again disappeared and suddenly pops up at the place I lost it, so I have to run all the way back (again, not fun). Got disconnected several times again and gave up. Waited for a faction member to be online and pick me up. Several hours later I got brought back to my ship and played for hours without any problem

A few days ago the same thing happened to me on the moon. But there I found my SV stuck in the green wall (about 100m high). When I used the cb command to bring my ship down, only then it got moved back to the original spot where I had lost it. and had to run back to pick it up.

So I don’t only need to run to the place where my SV ended up, but run back too.

The experience with entering the planet from orbit. I tried to enter, but got pushed back out. so going from -150m back out to +1000m. Tried to enter multiple times with same result. Prob because I was disconnected. Flew my SV up 1000m and relogged. Found my SV at the entering point of the orbit/planet and was glad i did not fly out 5000m to relog :stuck_out_tongue: It did not move back to the point I relogged though and I could hop into the SV and enter the planet.

Also, I don’t know if it is EAC related. Could be, but I don’t get an EAC msg. Only once I could not get back because of an EAC msg. Reinstalling the game fixed that and other than that, no EAC that I am (made) aware of.

Hope this gets fixed soon, as it is really impacting gameplay for me.

aernoud

Hey thanks for the info. Yes those messages (should be gone now again) were made by the devs to help us track it down. We are testing this with one player in detail, he has it constantly. If you want you could also use the steamtest branch to see if that helps.

We still have no clue what it is.
Its not our tool
Its mostly/only on our server
Is it only on EU server or also NA? Maybe the provider?
Its only the upload connection form player
Its not with every player
Some have it from time to time, some extrem
Seems to be since 2-3 weeks

So we and the devs are still wondering why… But hope the current steamtest fix will bring positive results. If so, then its a network issue with the player-internet-connection on a large server. But that could be fixed then…

15:24 Zion

Ahhh ich kann nicht alles auf englisch erklären zu dem Dummen fehler sorry. Ich bitte um verständnis. das wird für mein Englisch mittlerweile zu komplex. 15:24 Uhr eingeloggt. Angefangen Früchte zu ernten zum nahrung herzustellen --> Disconnect, Taste P geht wieder nicht.

Was mir diesmal aber zum ersten mal aufgefallen ist… ist das der Chat weiter läuft! Ich selbst kann im chat nicht mehr schreiben aaaaber sehe wenn jemand im Global schreibt! HÖ? Also kanns ja kein vollkommender DC sein oder? Ohne Serververbindung wäre da kein funktionierender Chat! Kann das sein das die Tastaturbefehle abgekoppelt werden können? Ich lege jetzt mal das P Menü auf eine Maustaste und teste das mal beim nächsten DC.

Negativ Rekord. keine 35 Sek gebraucht!

I don’t know if its a coincidence but i may have found a workaround. I’ve spent a lot of time in the last few weeks on NA server and desynch and EAC kick started just before 5.1. When 5.1 launched if was barely unplayable, desynch every 2-10min so i started investigate on my side. I’m always in the top 5 players for ping and i know my internet is rock solid. So here’s what i have done to be able to play: I’ve disabled EAC in game options menu, and launched the game with EACLauncher.exe (Run as admin and Win7 Compatibility). I’ve also disabled Anti-virus real time protection (in my case Windows Defender on Win10 using gpedit). The game ran fine for the next few days till some patch went live. I decided to go back to normal to test it out and worked fine too. Then last night i got 5 desynch in a row with an EAC kick on the 5th time, always in the same ships, tryin to move stuff from/to inventory. I went back to the settings i mentionned and worked fine for the rest of the night and this morning. I’ll see how it goes tonight and i’ll let you know.

On a side note, i had the exact same problem when i was playing Rust (Also Unity engine) a years or two ago. It took the devs a few weeks to find what was causing this to only a few players.

2 Likes