HWS Connect not connecting

Hello, I have been trying to connect to HWS Connect with no success. I am using Firefox browser and signing in through Steam. I get to choose server and when I go to click on the EU server nothing happens. If I click on the NA sever then it tells me I am not connected (which is fine as I have not played on the NA server yet) however I play the EU server and nothing happens when I clik the EU link.

It has worked fine in the past but I did just get warped out of a planet recently.


I just reworked the AJAX backend. So you can now refresh your data without choosing the Server over and over again. Could be that you got me during compiling the code.
Please try now again.

Tested it with all latest Browsers - working good.


I can see the various information that I can look at, but when using my Opera browser it still thinks that I haven’t played yet.
I still get the message saying I haven’t played yet.
If I try to access my player information it just jumps to the top of the page with that message there.
But I can just use IE instead, its not a big issue, I use IE for other pages as well anyway.