Ore in Home world space

A faction member and myself have gone to Homeworld sector’s planets a few times now, but every time we find a large ground deposits it says 100%but nothing is there. I was wondering if it was a visual bug for us or if more people are experiencing the same.

Did you even try today after the 9AM restart? That was the case yesterday but should be fixed by now

1 Like

Sorry, tried last night but went to bed shortly after. At work right now so I haven’t tried in the past few hours. That was a very fast response BTW O.o


Yeah !!!

I checked today after 5pm and still there is bedrock above resources on iceworld.
On lavaworld I was able to mine some resources but some were near POI and you cant mine near POI.
Waterworld 0 deposits.
Magma planet 0 resources and 0 asteroids.
Most planets have few resource veins with ~500-800 ore. Hard to find bigger than 1k.

On HWS we had 5x 1kk iron ore veins and similiar on other homeworld like planets. Also deposits on other planets were bigger. With all autominers which didnt deplete ore people were able to mine tons of resources and put them to OCD. I think that its not fair for new players. Will there be any changes to those planets which I mentioned?

Been bugging Rexxxus to fix this and adding multiple 20 to 30k deposits. Within hours of restart all the good stuff is gone

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.