Stuck on mission in ECC Flying City

======= NOTICE FOR HELP =======

What happened: Stuck on mission in ECC Flying City
Player(s) with issue: MiroZPraglu
Server: EU
Time (cb:time):
Playfield: ECC
How can we help you now: Advice

Hi, I am doing the Flying City mission, found the trap, then double trap, then found the ring at the bottom of the city. Switched all levers for first numbers off and on, mission checkboxes are checked now. But what now? No way to get from here, only jump. I found the hidden caves above all levers, but nothing is there and nothing happened. There is a SV parking just on front of number 5 lever, is it the problem?
I am really clueless, pls advice what to do…

Can you please share a screenshot of your PDA?

There are loot if you are not too late. It does regenerate over time though

Didn’t found any loot yet.
First I found the door in the highest room, then the Open the orange shutter door got checked (if I remember well I went up through orange colored lift and there was empty container), then I returned down and was running around city until I found a way into the trap (by climbing the building and jumping in down).

EDIT: I dont see the pictures in IMG tags…dunno why, so here are the links…

EDIT2: Asked for help, neat player took me from there to my SV, stucked no more

1 Like

Ok, returned for this after some preparations (backup).

Mission still broken for me.

What I did:

  1. started mission
  2. visited city
  3. found the door to the highest room (or at least I think - it’s door with the code you get around the levers in point 4). But it was open and the green container there was empty.
    Mission tasks Find the highest room and Open the orange shutter door got fullfiled (checked).
  4. Then I found trap building and double trap and the glowing walkway and levers with numbers. They were switched on, so I switched them off and on and mission tasks Find nth number get checked.
  5. Now the problem is that there is nothing to do next. No way to get from walkway, only jump down (or ask for a ride).

Is there something I missing? What should I do next? And I found those little caves (rooms) - I dont want to spoil where exactly. But there is nothing there.

Not sure, if this is a mistake or I am missing something…

Pls, answer or PM
Thx, M.


Rex is on vacation right now. and I have not much clue about the missions :expressionless:
So we might have to wait for him to respond end of the week.

No problem, it can wait, thx.

And my problem is that I fulfilled all steps, and finally that opened green doors but this step isnt checked so all mission cannot be completed ;.; . I tried to open and close this door from levers under city, then by lever inside green room, but nothing happend with mission :frowning: . I have to open green door still.


I’m back and check this issue now. We will recheck the EGS Flying City for the coming Ninja Mission anyways.
I’ll keep you informed here.

Ok, I found the problem and fixed it.

Please test after the server restart at 11PM again.
BUT you have to activate the PDA mission “Flying City Special Mission” and then retrigger all 4 green door lever again!

Let me know if it worked then.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.