Alien city mission bugs

======= NOTICE FOR HELP =======

What happened?
=> 5 of us fought through the alien city mission. We encountered the following issues.

  1. (MAJOR) In the city map, there was not a single alien loot container. The map was full of ammo controllers having only generic and useless loot (like 10 shotgun ammo and such). We suspect some block ID changed, because that amount of standalone ammo controllers just looks very suspicious (and people recall there were alien lootcrates on the map before)

  2. (MINOR) Respawning at the medical chamber always throw the user to the very first medical bay of the map.

  3. (DESIGN FLAW) The end map loot room mechanic was broken for half of us due the unreliable teleporting and we got nothing: as the lootroom timer starts when the very first player enters to it, the rest of the people (who loads slower or not load at all) had no chance to grab a loot.
    1 player didn’t even see the lootroom, 2 players had like 10 seconds…

Its also unclear whats the point of the timer there: after 1-1.5 hour of fighting, why we get only 30 seconds (or a minute best case!!!) to get back something?

Player(s) with issue? (steam name)
=> JVI folks

Server? (EU or NA or RE EU or RE NA)
=> RE EU

When did it happen? (Use server time: type ingame cb:time)
=> May 7, around 22PM

On which Playfield?
=> Alien City mission.

How can we help you now?

  1. Review the ammo controllers on the city map and change it to something meaningful (alien lootcrates were there before?)
    Attached 2 screenshots showing the ridiculous amount of ammo controller blocks…

  2. Maybe reorganising the location of the medical chambers can solve the issue.

  3. Overhaul the ending lootroom - just add it to the map (should have no teleport and timer)

The teleporting mechanism is unrealiable (as an earloer ticket shown, teleporting breaks in 10-20% of the cases for lots of people), people might need up to 2-3 minutes to load, and the mechanic just simply denies the rewards

What is the point of the the timer, after 1-1.5 hour of fighting?

Incorrect loot containers in a random oom and the room with the stargate at the end.

The final loot room sounds good on paper, but I got infinite loop half the time on teleporter. Can we remove that system and just have normal loot plz ?

this is a very strange mission.

  1. more than half of the territory simply does not need to be passed, why is it?
  2. containers with ammo are really very suspicious, they are useless
  3. exit token (did you find it? I found it) is not needed to exit or to receive a reward
  4. there are 2 NPCs on the map who don’t talk
  5. a room with a reward … ordinary. The same as for the mission with three waves of monsters, which is completed in 5 minutes. Is there a difficult, long mission for the sake of several containers?

I get that its a new way of doing things, but that timer on the loot room is very unfair for people who have slow connections, can take longer than 2 mins to just get past the teleport loading screen.

the weird ammo loot boxes in the mission feels like someone hit “replace blocks” command by mistake or something, they just clutter the place, nothing really in them.

I like that we have to find a key or something, that was a nice touch,
but the teleport loot thing doesn’t really need its own timer, since the mission already has its own timer anyway.

Thanks for the feedback.
I’ll work on it asaic.

Intentional as announced. All the reward loot is in the Treasure Room now.

This is randomly done, can’t influence it. But for the future a system like Alien Asylum makes sense, to have “Savepoint Teleports”.

I can’t fix Eleon’s bugs about teleportation. Patch 1.8 will improve it though.
The alternative is maybe to spawn the Treasure Room in the same playfield like in the Horde Mission.
Teleports within a playfield work flawlessly as far as I know.
Overall the Treasure Room is the best way to balance loot properly, fair and maintainable. (inspired by Lost Ark, Diablo and Co.).
It will be improved for sure though, especially the cooldown time, because once set, it can’t be changed during a season. It’s hardcoded written in many savegame files.

1 Like

Because this isn’t true at all.
It works for many without any issues.

Uh oh, you were fast responding :slight_smile:

Regarding teleport: it is a regularly coming up topic in the ingame channel of RE (typically some newbie first time encounters it and asks about it), and the conclusion it is for everyone, at least the vocal playerbase - but let us be precise then and say: a significant amount of players had it already.

(so far I hadn’t see a player in the ingame channel claiming he never ever had the teleporter bug, apart from you mentioning it when u tried to troubleshoot the issue couple days ago in a ticket :D).

(But I let it go anyway, we tried the mission, it wasn’t too much fun, pretty resource consuming and at the end I got nothing. (even if the teleporting works, the treasure room mechanic is very strict, so it doesn’t worth the effort. But its just a personal opinion)

Just one more comment: I recently had TP bug even on the same playfield.

But really I let the issue in your capable hands, so take my report as a feedback.

I can confirm that teleporters are also buggy when moving within the same sector. I often get infinite loading when teleporting from a ship to a base I’m near.

It works for many without any issues.
nah, thats not true
some do not have problems, because they simply stopped using the teleporter at all.
my friends often face problems with the teleports.
moving to the ECC sector by a group of people by teleport is a guaranteed problem for someone.
In chats every day requests for help to fly when the next rookie is 30 km from the nearest object in space.

I’m not demanding anything, it’s just a clearly unfortunate position, saying that for many everything is fine when everyone has problems.

1 Like

In the past couple days I seems to be able to mitigate the issue by killing the game from task manager IF the new playfield does not load in 30-60 sec (so I downt wait for long minutes anymore hoping the loading finish. It wont.)

When I relog in these cases, I will be at the target station, but cuple blocks away from the teleporter station (yes, sometimes under the POI, sometimes in a block, sometimes above the teleport pad couple blocks).

It could be still risky in case of some pois (eg you get locked in a room where all the exits ar faction owned so u cant open…), but as I mostly use my own teleport points and some “safe” NPC ones, it worked well for me. (in the past 3 days I had like 6-7 teleport bugs, and had 100% success tratio to mitigate it, I never landed in the void kms away from everything)

Indeed, it would not help with the lootrooms (so I also don’t think its a safe approach to use teleports to get the reward), but you might give a try in regular playthrough.

Just to add some inputs.
On our 6 members party, only Firebeard could load the first 4 tries.
We were 3 in on the last try, two ragequited and one couldnt get in.

I have the teleport bug in the same system (infinite loop, need to kill via task manager).

I do not understand how it is balanced or even good design thinking. Please do not copy Lost Ark, this game has terrible mechanic based on whale monetization. Having rewards in personal or non personal box seems the same to me, but it works 100%.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.