Anyone else unable to connect?

I seem to be unable to connect to any multiplayer server, when I do I get an internal error.
If I click continue I’m returned to the game menu.
If I click quit and mail I get an error from my browser about not having a mail service set up as I dont use the servers integrated mail service.
I verified the game files and have all drivers updated, it does not change anything
I already bug reported it, but I wanted to ask if there is anyone else who has problems with connecting to multiplayer.


Just read and tried to join Official Crap Server, it worked. Not sure if that can help but try to delete cache

c:\Program Files (x86)\Steam\steamapps\common\Empyrion - Galactic Survival\Saves\Cache\

Ok, this is one of those “DOH” moments.
I cant connect because the servers I tried to connect to(including HWS until just now" was running 2.3.2 while I have already updated to 3.0.
So the cause for the error is simply incompatible builds.
It just occurred to me now, didnt even register in my head earlier when trying to connect.