CB:Reset doesn't reset characters

On my server I am running Reforged Eden and “Empyrion Web Access” mod and with EMP Admin set up when someone types CB:Reset it tells them they have been reset and to wait for 6 seconds afer they get kicked to login again but the Character is still intact and not sure why.

Have tried running it as admin and UAC is off and the player files are not read only.

EDIT: Later I will try and stop Empyrion Web Access mod as it does admin related things also to see if that fixes it.

Does anyone know what might be causing that?


I suppose you use EAH Full and EAH runs on the server, right?
When a player runs CB:Reset, the player file is just deleted. Now it could happen that the game is so slow that it saves the file, after EAH deletes it. That would be my only thought. Maybe you could check that.
Is the player kicked properly?

It’s EAH full and it runs on the same machine.

After they type CB:Reset it kicks them properly out into the main game menu with a message to rejoin the server after 6 seconds.

I thought it would delete the player file by the player ID, and maybe it’s because I am running two admin programs meaning the file might be in use.

I will check on it more tomorrow and let you know what I find out.

Sorry for late reply.

Tried it when disabling the other admin program but got the same issue.

Looked at the \Saves\Games\NewPublic\Players folder and the Steam ID file .ply of mine for example then when typing CB:Reset on my server while in game it asks if I want to restart my character etc.

Then it kicks me to the main game menu and disconnects me from the server with a message saying to reconnect manually in about 6 seconds.

However it seems that EmpAdminHelper V01.59.0.3 Full is not deleting this ply file.

But if I delete it manually it resets my character.

Not sure why EmpAdminHelper V01.59.0.3 Full is not deleting it yet.

Maybe it’s a setting not set up correctly?

hm Only problem could be either that the path is not set, but then you would have many more issues, or the problem mentioned above.

Could you send me in a pm your EAH logs from that day. In the EAH folder under Logs.
And maybe let me know what time you did the cb:reset so I can pinpoint it in the logs

Thanks when looking at the logs I found out that it was looking in the wrong folder for the players data.

The EmpAdminHelperConfig Dedicated.yaml filename in the setup was incorrect and after fixing that made it work and now CB:Reset appears to be working fine now.

Just one more problem but I think someone may of mentioned it with a fix on another form is when I go into Config / Game / Opens the Game Options it gives out an Exception Error I think because I am running Reforged Eden.

Might be that you have a old not valid property in there DiffEnemySpawnRate. Should tell you that in the error. Just remove that form the config. Its not a valid property in Empyrion anymore.

Thank you very much for your help and removing that part in the config file for DiffEnemySpawnRate fixed that issue also!