Chatbot not working

Chatbot isn’t working on my server at all! :frowning: Is there a configuration that needs to be set, or some way CB needs to be activated?

yes in the config of the tool.

Thanks for the quick reply. I have the chatbot option turned on in the config menu but no commands are working, including commands I add to CB, as well as the default commands.

Is the tool connected (green) to your server?
Lite or Full version? What version of the tool?
What happens if you type cb:? in chat?

Yeah, I’m connected to the server. Able to send Telnet messages.
Using the Lite version.
Nothing happens when I use the command in-game.
Think switching over to Full version might help?

Ok, I tried starting it up on the full version and it still isn’t working. The tool is seeing everything in chat, so I’m not sure why it wouldn’t be triggering chatbot.

Version is 1.38.2

Thanks for the help, BTW!

Okay! I have it working now. Last thing I did was open the config.xml for the tool with a code editor and changed the value of ChatBotOn to true.
It was still set to false. Not sure if that’s what did it, but thanks for the help!

Hi there - I have the same issue. Chatbot is not working, I’m using the Lite Version, I am conected, Everything else seemed to work fine. I can chat as an admin, change inventory and so on. Chat Bot is activated in the config and I made sure it is also in the xml file. there is no respond to any cb commands nor am commands (am is activated too).

I appreciate any suggestions.

Do you see the chat in the tool?

Hi and thx fpr the reply. After 5 restarts of the tool it worked. I did not changeged anything furthermore - just repeatedly restart server & tool.

Hello - I too am having some Chatbot commands not working. What does work is cb:? and any listed item I placed in Chatbot_options.XML. Also cb:survival works. CB:Time also works.
The ones that doe not work are the Activate_GetShipDown=“true” Activate_GetShipHere=“true”. and as you can see it is true in XML file.

For example CB:GoToShip:1124009
did not work for this player.

I am running Lite v01.40.3.7
Any suggestions?


sorry everything that has to do with structures is not working in the lite version.
Thats the main limitation why its called lite