Donation - unsent package?

======= NOTICE FOR HELP =======

What happened: I made a donation today for a Large package of resources. After a few minutes and the command still not working, I tried again, this time for a medium package, and still nothing.
Player(s) with issue: Talon
Server: NA
Time (cb:time): 4:02 pm. second purchase at 4:08pm
Playfield: Write here
Structure Name(s): Write here
Structure ID(s): Write here
How can we help you now: I’d like the resources, if possible. No refund needed, as i want to support the server, but the resources would be good too- Halp pl0x.

1 Like

Admins have to manually confirm and activate your commands usually takes a few hours especially on new years :P, thanks for donating btw :]

Thanks. Didnt realize that it required that. In that case, i’ll just wait for them to pop on ^^

I just gave it to you.

Thank you so much for your support and happy new year!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.