Duplicate in some EAH data

I’ve been seeing some duplicate data in my EAH for some time now. I tried to ignore it and just use the tool on things that were useful to me. But it seems that the problems are increasing, and I really wish I could solve all this once and for all, if you can help me.

my server

I’m hosting my Empyrion server at GTX Gaming, there I don’t have access to the graphical interface, but they manage to leave the EAH master installed, and I use the slave version on my PC to manage it.

My problems

  • Duplicate characters (see image);
  • Chatbot is announcing the commands several times (see image);
  • Autominer when the player typed the command to buy, sometimes buys lvl 1, then 2 and 3 at the same time, with a single command! Now it’s costing a lot more than I set it up. I had left the first one for 10k, and there was a player that showed me spending 200k to buy it.
  • I can’t edit the player’s inventory anymore, some character editing options just don’t work (they don’t open, there’s no reaction in the option after I click).

Well, that’s what I remembered for now.

There are so many problems that it drives me crazy! I wanted to be able to delete the entire tool and re-install it, without affecting the players’ progress. It would be possible ?

As the tool is on the server, I would have to upload the files via ftp, and I don’t know if just downloading the site’s version and putting it on the server would work. I wanted some help before moving there.

Or if the problem is easy to fix, that would also be an option!

I appreciate any help!


duplicate entries means that somehow EAH is running twice on the server. Maybe due to a crash… not sure. I heard this happend a few times with hosters.
You would need your hoster to stop all EAH processes and best even delete all *.dat files in the EAH config folder.
Then start EAH once.

I don’t have access to be able to fully stop the tool. Would it work if I uninstall from the server, delete the files and install again?

I will show below the only interface I have connected to the tool.

I do not know. You need to ask your hoster.

Thank you very much ! The problems of the duplicate entries were solved with the server hosting team, were quick to solve.

Now I still need your help :slight_smile:

Some functions still not working, as I said earlier. Because they simply do not open, nothing happens when I click on these options (see image).

Very rarely I can open this interface when I am opening the EAH application, but as soon as the tool connects I can not open anymore.

Would you have any idea what you could do?

Thank you for your help!

Do you get any error message at the bottom of EAH when you click on those entries?
As mentioned before. It would be good if you delete the EAH databases/files on the server. If you work with those duplicate entries a lot of errors are to happen.

I deleted all the files, I had tried before, but I found that two of them were still there. Had to ask hoster to terminate tool process to delete. Then I re-installed the tool and tried again.

I deleted all the .dat files (see image), I opened the tool and it really was wiped. But the problem continues, and no error message appears.

I recorded a video to see if it helps.

The tool is out of date, I saw that the process to update it, requires that you have to stop the tool and start it again, but I have no control over this, I’ll check with the hoster team now to see if I can.

But I don’t think this is the problem, because before this update the tool was up to date and this problem continued.

Ok good to see the duplicates gone now.
In the bottom it speaks about a Version mismatch between EAH. Make sure you have the same Version as the master tool. you can see it in the message (sadly its not good quality, so I could not read it).

If that does not fix it either it might be the new security setting. Then it would be important that the Slave rights in the master slave config is set to All or Administrator. If you can open the master config it should be shown in the “Master/Slave” tab.


Ready, I updated the tool, along with the hoster team, I checked this option in the “Master Config” and it really is as “all” the Slave rights.

But the result is still the same as shown in the video.

There are no more errors in “Lasted Wanings”, I simply click on the options and nothing appears.

OK, that is strange. Could you send me the EAH logs from the master and the slave from today. And maybe let me know what time you tried the function?

Logs are in the EAH installation folder under Logs and have the Date in the name.


These are the files in the “Logs” folder of both the Master and Slave tools.

I tried to use the function before saving the log, so it must be one of the last things, it was around 17:00h (local time)

Hey @Jascha “server hoster” here (GTXGaming)

Let me know if I can help in anything to debug this issue, I can provide you with a test server if needed.

Thank you

Thanks a lot.
Sorry for the issues. So the error that is thrown:
“SyncClientHandler: Event Error ReadOnly seqnr 40781”
means that the slave has no rights to use that function.

So in the Master tool the Slave rights seem to be set to a wrong setting.
It should be All or Administrator (best All).

In the Config\Settings.xml this line should be in:
It should be a 0 for All

Is this this the case? If it is already set to 0 or 1 then it might be a EAH bug. Maybe then set it as a test to 4 (in case there is a simple < > issue).

I’m just testing it localy and I fear there is a bug in EAH. Will check and fix it now

EDIT: I’m very sorry. Its an issue with EAH. I will put out an update in a few minutes.
Thanks for letting me know

Update is out.

Sorry again for the issues.
The update is especially important on the server.

Everything is perfect now!

I had some appointments yesterday, so I ended up taking a while to test.

Many thanks to @Jascha for the support and the folks at GTX Gaming who were quick to help me with my issues.

1 Like