EAH Starts server but has no feedback

Hi, so i been i bit frustrated over this, i have tried to fix this issue a numberous times. But cant seem to fix it.

Anyhoots; I am running Full EAH ver.

What happens: Server is all config, start the server, No warnings, and EAH indicates the server has started. Howvere the RED Button does not turn Green
The Server does show up in Empyrion Server list and people can join the game.
There is no feedback to EAH on who is on, and/or any of the features will load.

What I have done: Uninstalled and reinstalled Emyrion Dedicated server, used same server files, as receated new server files, installed into another folder with same result, using Full EAH - which i downloaded from the site.

Any suggestions would be great.


if EAH runs on the same machine as the server: Check the EAH config API port. and make sure that one is the same as in …SteamLibrary\steamapps\common\Empyrion - Dedicated Server\Content\Mods\EPM\Config.txt

Then restart EAH and also the server (game)


Is there a fix for the above? My server + EAH was working fine till the 10.5 update.
Now EAH refuses to communicate with the server (on the same machine) yet i have people connected from all over the world.
Highly frustrating to say the least!

Yes, the API port is the same.
It was working. All i did was update.


FYI. I downloaded (from the EAH site) the latest “10.5” version yesterday to make sure there was no recent updates and that i was on the latest build.

The new EAH Version comes with a new Mod. A common problem is when he can’t update the mod. If you start EAH, do you get new Warnings in the Latest Warnigns section. If so what warnings?

In case you have Problems, please check the following: Go to: …Steam\steamapps\common\Empyrion - Dedicated Server\DedicatedServer\EmpyrionDedicated_Data\Managed and check that there is no EAH_Data in the folder. If there is, delete it. then goto: …Steam\steamapps\common\Empyrion - Dedicated Server\Content\Mods\EPM and check the EPM.DLL and the EAH_Data.dll. What Date are they from? Should be from September

Often the Problem is if EAH was started while the Server is running, then he can’t replace those Dll’s

If that does not work, let me know and I will check it.


Thanks for the help.
The solution was the “EMP_Info.yaml” was missing.
I validated my install and that file showed up.
Then launched the server and it connected straight away.

Thanks again

1 Like

ill try that, i been running the server - old school - per say, but ill do a check tonight and see if that fixes the issue, and get back to you

okay i checked what you mention, was no EAH_Data in that folder, and the two dll files were dated for sept. However on a weird chance, i booted the EAH up and started the server from there and now it seems to be working properly.
I have a Green Server Light on and seems to be running fine.
Ill do further testing to make sure it is running properly, but wanted to let you know.

1 Like

Thanks for the reply. I will check everything you say later today and let you know. (at work at the moment)