Elemental Space Race

It keeps teleporting me back when I try to start it with another player. I’ve done it with three different ppl and 2 of the 3 others received the award.
I’ve attempted it 5 times now and last 2 attempts are rejecting me and I’m yet to get the reward.
Why me!? :frowning:

Not only you. This is a bug available since instance release.
We are trying to find the root cause and fix it.
For now I tried to remove the folders so please try again next time.

Well it let us fly the ships but my pda would not confirm I hit the objectives to mission. It never even confirmed I got in the SV even though I was flying it through the hoops.
Other guy has already completed it.

Did you activate the mission first?

Yes of course. Then I deactivated it and reactivated it too to see if that would work but nothing.

Then the trigger might not got you at the front LCD screen. I will check the Freelancer Race mission asap again. But I guess a bug with the sensor signal logic if you were maybe with another guy in the trigger area at the exact same time.

It worked this last time. Thank you!