EmpAdmin Helper V01.59.0.1 Full - GameOptions.yaml not found

I know there are other topics on this but it still seems to be a reoccurring issue so I’m going to try to be super specific to make it worth posting about again.

I’ve already had a dedicated server in which I used this tool for management running for nearly 400 gameplay hours. I lost that save, yes I was stupid by not properly backing up, but wasn’t deterred and started the process of reconfiguring a server from scratch.

I have the server working with EmpAdmin Full, and I have no problem playing games but I can’t access the actual game options to adjust any settings. When I click on Game it bring up an error box that states the GameOptions.yaml file can not be found.

So, I went about trying to figure out where the GameOptions.yaml file was actually supposed to exist so I could just create it myself and manually adjust the settings. I would really like for someone to check me on this but I think the file should exist at:

  • C:\Program Files (x86)\Steam\steamapps\common\Empyrion - Dedicated Server\Saves\Games{SaveGameName}

But, just to be sure I’ve dropped the file in the root Empyrion - Dedicated Server directory and the config app still won’t see it.

Next I just manually edited the config values I wanted in the file and then started a new character in that save. After drowning myself to see what happened to my backpack I could confirm that even manually editing the config values did not alter the server game.

Is there a config line for the admin tool so I can manually point the tool to a GameOptions.yaml file? I’ve already tried removing everything Empyrion and tried again to the same results. I even tried creating a CO-OP game and then copying that save file over and directing the tool to use that save and it still could not pick up the GameOptions.yaml file.

Thanks for reading the rant.

TL:DR EAH can’t find GameOptions.yaml and I’ve tried quite a few things.


this is correct. Make sure your dedicated.yaml does not hae another “Save” location mentioned and that the Save game name fits.

In EAH in the Config you need to set the Game path and also select the deicated.yaml file that will start the server.

Then it should work

Thank you for the quick response. You’re absolutely correct, it should work. Actually, it did work once I removed the apostrophe from the server name. I’ve been a developer for 10 years and somehow I both knew better and still put an apostrophe in the name and also missed it this entire time.

This tool is fantastic by the way, thank you. Outside of the need for a little extra verbose messaging I love it.

1 Like