Epic radiation boost vanishes when equipped

======= NOTICE FOR HELP =======

What happened?
=> Used level 2 TEAMS tokens to purchase 2 epic radiation boosts. Boosts vanish when putting in armor. Lost the 1st, then recorded the second.

Player(s) with issue? (steam name)
=> Bob

Server? (EU or NA)
=> NA

When did it happen? (Use server time: type ingame cb:time)
=> image

On which Playfield?

Structure Name(s)?
=> Armor locker on HQ was used for this:

Structure ID(s) (Open ingame console and type di)?
=> 18012

How can we help you now?
=> Just reporting the issue. Experienced this situation last season and have confirmed it still exists. No refund is needed.

Same stuff for us, epic boosters disappearing every time we tried to attach them to any armor. Problem since HWS 12.

add: its for radiation boost only… hmm, need to check others

i tried all of them last season and radiation was the only one that did this. i also noticed it is not colored the same as the other epics. more purple than pink. i have confirmed multi and jetpack boosters work just fine…other than being nerfed :wink:

You got regular medium in your video, but i tried to attach them to epic medium, as i remember.
Anyway, after disappearing i stopped trying.

Unfortunately I forgot to remove them. Achilles didn’t know it too and added it for TEAM.

Should be gone after the server restart now.

I couldn’t make them to work at all.
If you want a refund, please contact Eleon :see_no_evil:

1 Like

no worries. there have been jokes about my “hotbox” ships that cook their pilots. wanted to see if i could find armor combination to troll back :wink:

1 Like

just noticed the epic radiation boots are still available at the freelancer TEAMS building. was tempted to store them until they are fixed…

hm? In terms of reward?

can be exchanged for level 2 certs. will confirm and screenshot when i get home.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.