I need help please Trition Adventure Mission

======= NOTICE FOR HELP =======

What happened:
Not sure what is required for the next stage.
Have my cave miner reward.
I have the coordinates to Pheonix and the coordinates saved to map, but it is unclear what is required next. The story indicates the worm caves are on Trition.

Simply need to know if something has not occured?
A pointer to what I should be looking to do would be helpful.
Many Thanbks :slight_smile:

Player(s) with issue:


Time (cb:time):


Structure Name(s):

Structure ID(s):

How can we help you now:

to complete the Phoenix quest, you just need to go to the Phoenix system via the sg coordinates you found by the cave reward ship spawner. there is a second quest on Triton to hit the worm caves scattered around the planet.

Hiya, Thank you for your response. I really appreciate the assistance.

The mission I am attempting to complete is “Trition Adventure Mission”

I have the cave miner reward ship. I have the coordinates from a computer station, and I have “coordinates saved to map” from another computer station.

The stage I am trying to complete is called “Find the coordinates” to which I believe I have done but it has not ticked off. It does not say “Fly to Pheonix to start the Pheonix mission.” It is not clear what I need to do to get it to tick off.

Any help would be greatly appreciated.
Thank you.

Yes, select the phoenix mission again and go back to the cave you found the ship in. There is a large LCD screen with 2 switches on either side. Turn them on. Rex likes to reward exploration so always check your surroundings for subtle hints and clues, not all are clearly marked but they do exist :wink:

Hi Bob,
Sorry I did not make this clear, I have already found the screen, flicked the switches and received the coordinates. I have also received the message “saved to map”

The task of “find the coordinates” is not yet ticked off and I am unsure of what to do next.

Please advise. Many Thanks.

Welcome to HWS @TheSmell

I have read everything but am bit confused because you two speak of 2 different things.

There is the Triton Adventure Mission:

And the Phoenix Quest

Both have something to do with “Coordinates”.

If it is the Task “Find the last Coordinates”.
The description says:

It would help if you can show me a screenshot of your current progress in-game by pressing F1?

Hiya, Thank you for responding. I really appreciate your help.

Here is the screenshot you requested…

I believe the confusion is because the two missions overlap. Not an issue. No one seems to know what is involved in completing the Trition Adventure Mission.

I have serched the base for coordinates for the worm bases but not been successful. I have been confused by the Pheonix coordinate start mission.

I also have the screen saying “coordinates saved to map”

It is unclear if something went wrong or there is something for me to do. Either case, I simply seek clarification and maybe a hint.

Many Thanks.

ahh yes! apologies. this one was a bit interesting. on the Triton planet there should be purple HUD markers showing the worm caves scattered around the planet. they are all connected via teleporters. warp to and investigate each one. this mission i have only done once and do not remember all the steps from memory. i am usually on in the discord lobby if u are up to streaming the adventure.

Hi Bob, Thank you for your reply. I have already jumped to all POI locations, calculated the code and received the reward ship. It is the next step which is unclear as indicated by my screenshot.

Many Thanks :slight_smile:

Hi @TheSmell,
I’m sorry for the confusion. For completing the task ‘Sighting of the Alien Worms’ the Mission needs a signal. That signal you can send by activating the screen lever, which turns on the Coordinates to the Alien Worm.

It seems, that the game didn’t got this signal. Maybe just try again.
And make sure, that the Triton Adventure Mission is set to active.

Maybe I exclude the Phoenix Mission distraction to make the quest flow easier to follow…

Let me know, if you still have the problem after trying to deactivate and activate again the ALIENWORM SIGHT lever.

1 Like

Hiya, Thanks for your help. I found 3 levers. I switched them all. multiple times on multiple occasions.

Sorry to hear @TheSmell
We will improve it for HWS 12!

For now I made sure that the “AllowManualCompletion” setting is set to true.
That means you should be able to complete all Actions manually, in case they are not working, by clicking on the Action Checkbox. Can you try this please?

Hi RexXxus, Thanks for your reply. I am currently unable to manually complete the step. Do I need to update my local files?

Hmm no.
Try to deactivate the Chapter.
Close Empyrion.
Start again and join and start the Chapter again. Then check the checkbox again. (this should clear any cache
If that does not work… uff… nothing I can do remotely anymore :frowning:

OK, I found out what was causing my challenge.

Somehow the mission became deactivated. When I was looking at the mission after your suggestion I tried to manually tick it off but it would not work. I then noticed the “Activate Mission” button was highlighted. I clicked it, and instead of manually clicking it I wanted to try and complete the step normally so I went back to the bunker, flicked the switch, and the step ticked off successfully.

There is no need to have this step manually completable.

I am not sure how the mission deactivated. Maybe when I actrivated the Phoenix mission?
I have learned a good lesson which I will be mindful of in the future. Hopefully this will help others avoid falling into the same situation.

Many Thanks for your help :slight_smile:


This game seems to be mostly geared to teach you to learn from your mistakes. Perhaps the developer’s goal all along :thinking:

Maybe as an Idea, not sure how feasible this is, or if it already does this (I did not notice), that when you go to activate a mission the pop window says “You’re current mission will be deactivated!” but I am only guessing this is what it caused to deactivate.

Thank you Bob and RexXxuS.

1 Like


Yes, the Quest system is still not that well improved like you know it from other games. But I will make a workaround if this happens to many other players too.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.