Main story Quest Chapter 3 bugged

======= NOTICE FOR HELP =======

What happened?
=> Main Story quest is bugged on Chapter 3, it says to go to the Trade Station. I arrived but nothing updated and I cannot check the box to progress the quest.

Player(s) with issue? (steam name)
=> Clovis Kai

Server? (EU or NA or RE EU or RE NA)
=> RE NA

When did it happen? (Use server time: type ingame cb:time)
=> Friday 07, October 2022 22:21

On which Playfield?
=> Alpha Starting Worlds

Structure Name(s)?
=> Trade Station Alpha

Structure ID(s) (Open ingame console and type di)?

How can we help you now?
=> Information to progress or reset the quest so it goes through properly.

try deactivating and reactivating the PDA mission in the F1 menu. sometimes a restart of the game is needed too.

I have done that, still it has not fixed it. Ive restarted the game, as well as switched missions but it just says reach trade station, I assume its the one called Trade Station Alpha but nothing happens when I get there. I have tried clicking the box because that has worked in the past but that isn’t able to work either.

After doing another quest it looks like that fixed my PDA and i got a waypoint.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.