PKA HV causing CONSTANT internal errors

This is total BS, every time PKA brings out their S*** HV, every time it fires its CONSTANT internal errors. This just happened on desert world, and was ONLY with PKA. They are actively exploiting it as they can keep moving while everybody else in the playfield is spammed

with internal errors. It is straight up cheating and needs to be dealt with.

We have not had any errors, until they brought their HV, as soon as it gets in range and starts firing all of us are unable to move getting Internal Errors one per each shot of his HV…

While this is happening to us he continues to move normally and simply exploits the bug his hv is creating.

We notified him and his faction in chat about this bug, and asked them to remove this HV from the battlefield.

They laughed at us and continued to exploit this known bug.

here is logs from the time:

21-06:41:26.057 01_41 -EXC- System.NullReferenceException:
at (wrapper managed-to-native) UnityEngine.Renderer:SetPropertyBlock (UnityEngine.MaterialPropertyBlock)
at Assembly-CSharp.ActionEventArgs.DeployDockingPane (System.String , Single , Boolean ) [0x00000] in
at Assembly-CSharp.XmlFileSite.DetachMenu (Assembly-CSharp.LineProvider , Int32 , ReferenceEditor , ViewInfo , Assembly-CSharp.ActionEventArgs ) [0x00000] in
at Assembly-CSharp.XmlFileSite.QuoteCommand (Assembly-CSharp.LineProvider , Int32 , ReferenceEditor , ViewInfo , ViewInfo ) [0x00000] in
at Assembly-CSharp.ServerFactory.OpenStub (Assembly-CSharp.LineProvider , Int32 , Int32 , Int32 , ViewInfo ) [0x00000] in
at Assembly-CSharp.DomainTable.OpenStub (ReferenceEditor , Boolean , ViewInfo , Boolean , SByte , Boolean , Boolean , Boolean , Int32 )

Best guess is the BP have an item that is no longer exists in the game, or have a property which no longer available, and every time its activated it errors out everyone within range who encountered him.

another example:

at (wrapper managed-to-native) UnityEngine.Renderer:SetPropertyBlock (UnityEngine.MaterialPropertyBlock)
at Assembly-CSharp.ActionEventArgs.DeployDockingPane (System.String , Single , Boolean ) [0x00000] in :0
at Assembly-CSharp.XmlFileSite.DetachMenu (Assembly-CSharp.LineProvider , Int32 , ReferenceEditor , ViewInfo , Assembly-CSharp.ActionEventArgs ) [0x00000] in :0
at Assembly-CSharp.XmlFileSite.EditDirectory (Assembly-CSharp.LineProvider , Int32 , ReferenceEditor , ViewInfo , Assembly-CSharp.ActionEventArgs ) [0x00000] in :0
at Assembly-CSharp.DomainQueue.RegisterControl () [0x00000] in :0
at Assembly-CSharp.DomainQueue.LoadContext () [0x00000] in :0
at Assembly-CSharp.LineProvider.UncheckActivity (Single , Int32 ) [0x00000] in :0
at Assembly-CSharp.AspectTable.ClearSelection () [0x00000] in :0
at Assembly-CSharp.AspectTable.ClearNode () [0x00000] in :0
at MBS.Update () [0x00000] in :0

(Filename: Line: -1)


I have witnessed this as well, I was there during this fight. It happened to us all across the playfield. They were even still over there in combat while I went back to base and still got the errors anytime their tank drove out to engage my guys. Anytime that tank came out every guy we had got internal error spammed. We have fought MULTIPLE clans and this doesn’t happen, We fought LoT earlier today… Didn’t get errors… Fought 5-6 different clans last night in a EPIC battle and no errors really… but then tonight PKA comes out in a fresh tank and it causes everyone to get error spammed. It’s not right using a bug to an advantage. It puts you at a constant internal error loop and you can’t fly your ship so you just fly right into bases… etc. I have tried telling them it’s causing errors and they continue to use it. That’s wrong if you ask me, I have had this happen to one of my guys tanks and we called a cease fire with LoT on Arma a while back… We backed off, He re logged and it managed to fix the problem from what I had seen. It has something to do with spawning in fresh vehicles/blueprints I think… I’m not very educated with the computer tech stuff but I have played this game enough to know what is going on, I have 1450 hours in this game and have enjoyed every bit of it. HWS provides an amazing server with some serious PVP combat… I recommend it to a lot of people, I want it to grow … I just hate seeing stuff like this because it kills the PVP experience for everyone.

I had the same thing yesterday happening, today I didnt even want to try going to desert,

Besides that, my turrets didnt lock or fire on their HV’s, but they could shoot on me just fine. When I kept getting errors and was stuck on clicking them away the vehicle stops dead in its tracks… I couldnt do anything, while they blew my sled and tanks away.
I tried 2 bigger HVs on them and 2 small ones, none fired.

I’ve had a FPS drop before, I’ve had the errors before, but this never happened to me before with this much consistency and or frequency. The only constant factor I do see is the HV of PKA causing those errors whenever it comes into play.

And the ridiculous low FPS, which was around 5-10 on lowest settings, just made it unplayable. This must have to do with the amount of entities in the playfield, and more importantly, the size of them.
The only thing that can take on a big thing with loads of guns is another big thing with loads of guns, so I think the only real solution to the FPS problem is reducing maximum size classes.

I am from PKA i will look into this for you but i know that they were getting internal errors too.
will let you know or rex know what i find.
thanks for letting us know.

The baseless accusations of a simple mind.

We were all getting these internal errors. The reason you see us still operational is that the internal error spam due to the alpha code stops happening if you re-connect to the server.

Pka is one of the most experienced fighting units with lots of hours in battle. This is why we have found workarounds and solutions when problems such as this rear their ugly heads due to shoddy alpha coding or netcode in the unity engine.

It happens to us all.

We made a test and send the Infos to the devs. (Thanks OP4 and PKA for that)
We found some errors that caused such disconnects while they were attacking PKA. But it does not mean its PKA. As its Alpha, many things could cause it. We will investigate further.

Devs will try to fix it before or with 6.0

1 Like

Guys remember and PLEASE keep in mind that the EU and NA server has a PKA faction. And even if few of them doing CSW because of name sharing they are not cooperate together.

So please always mention if it’s EU or NA server.

Thanks we will look into it.

Do we know the exact structure id number which is causing it?

They are talking about PKA NA.

I am confident it isn’t intentional, but If you can figure out how or why this happens you would be a life saver. I’m guessing they are talking about one of the leviathans or malitilda.

That are the two types of HVs they run. I’m sure they’d be glad to let you see their BP Rex. But the internal error thing is real and is hell. Something in certain structures become corrupt after taking damage.

On Arma there was a point after lot moved out that something got into a bad state and the solution was to avoid it, or on Arma when someone placed the dual towers base, it got damaged in a way everytime you got near it you got internal errors. It has sadly become the norm for any long fight on planet to get these errors.

I was under the impression it was related to structural integrity but that may of been a bit baseless. Because until this report I’ve only heard of bases causing this.

FYI Rex,
this seems to be related to the null pointer exception issue, particularly similar to the issue with the bp I sent you, that cause that error every time the ship was hit. However, The structure in question is not even remotely that close to the triangle limit normally, so I would bet that it is not intentional. Rather, it may well be the combat damage paste on bug that occurs when something is damaged, and it throws something onto the ship that is not supposed to be there. Note to people reading, this is different from the one where the ship you are fighting APPEARS to have a chunk of your ship on it. In this rare instance, the item is actually there. You can even walk up to it and repair the blocks, break them, etc. This is what caused the rock flipping on arma, where hv’s would randomly flip off into the sunset rotating around a chunk of rock.
I have noticed that blueprints made of ships with this seem to have a massive triangle count, as well as being generally unspawnable. If there is a backup of late afternoon from sunday when this is happening, and you can find the hv in question, you may well be able to see this in play. Just a guess.

But for the record, Everyone on the playfield was getting continue errors. Outright claiming that this bug is an exploit is a little outrageous, as there isnt anything out there that distinguishes if the error was caused by your own ships. If anything, what PKA suggested about relogging may be a clue, and a way to mitigate the frustration on both sides in the future.

Of course it is not intentionally because everyone get this error and it is an alpha game.

But let the haters fill their hater bottle they can drown themselves in it.


To a more meaningful content:
It would be awesome if someone can do a try and error scenario when the game crashes with how many triangles. Maybe we need to adjust the formula so triangles need to have a higher multiplier like lights


Hey Rex can you go read about the Helheim problem please. Thank you.

We aren’t just being cry babies because we are “losing” because we aren’t. We are just trying to fix this, they may not have done it on purpose but when they were told it was causing it and continued to use it is when it became wrong.

Will do as soon as I am back from work. It’s fiddling here on a smartphone

1 Like

Thanks mate appreciate it.

What Colin said is key, they were told many times that this error is happening and went well out of their way to use it to their advantage to the point after 5 minutes of errors I said to hell with it and let him finish off my sv. I’m not mad that I got killed, I’m upset that he used this to his advantage, knew about it and exploited it. I would rather the devs take out this game breaking notification and rather put a message in the upper right corner with all other notifications.

1 Like

Taco, this implies you know everything about the game and know for a fact 100% certainty that this ship was the issue. You’d be just as weary if pka asked you to stop using one of your ships because they believed it was bugged. I wouldn’t of trusted you personally because there is no reason you couldn’t lie, and there is no reason for me to trust your technical expertise (since I don’t know it) to debug the causation. It could of just been correlated for all I would know. (I was in bet at the time of the shenanigans)

The solution I’ve found for dealing with the internal errors is leave the playfields and come back. In an sv this usually includes me holding o and space to get up to space while tapping continue.

Either way no need for dramatizing this, jascha got on from what I understand it and helped figure out the issue. And that it was client side?

A lot of hate in this admin post…just sayin