Plausable Deniability Quest

======= NOTICE FOR HELP =======

What happened? Chapter 3 quest not letting me move forward. I am standing next to the guy on the tower ,quest active and nothing. I can not skip quest .

**Player(s) with issue? (steam name)**Maszaan

**Server? (EU or NA or RE)**RE

When did it happen? (Use server time: type ingame cb:time)
=> May 7th 2:39

**On which Playfield?**Haven

**Structure Name(s)?**Survey tower ID 3037

Structure ID(s) (Open ingame console and type di)?
=> 3037

How can we help you now?
=> Skip the quest for me or allow me to continue?

try deactivating and reactivating the quest. that sometimes works to let you continue

I forgot to mention I did try that several times. Logged and relogged as well

Unfortunately not easy possible. I would need to break and intefere what the Creator (Vermillion/Ravien) have planned for it and then allow it for everyone to skip, not only you.
So the best thing you can do is to ask the Creators here how to move on:
Reforged Eden Scenario | Page 41 | Empyrion – Galactic Survival - Community Forums (

Roughly looking you maybe speak of this here and this is all I can tell you:

So best to move away from the Survey Tower, deactivate the whole Chapter, logout, login and activate again.

User error. I started on Haven so I assumed this is where the quest would start. I ported to a secondary starter planet due to to many folks on Haven. As soon as I got near the tower it worked.

I thought I tried everything last nite. Spent 45m before posting last nite.

Thank you again for dealing with my newbness


until you go through it a million times or you ask questions, you just don’t know. That’s why I say the only silly questions are the ones unasked :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.