Scrolling in HWS Connect 3.0 either too unstable or doesn't work

======= NOTICE FOR HELP =======

What happened: Scrolling doesn’t work on pages with a lists in new 3.0 Connect.system doesn’t work.
Player(s) with issue: kirby
Server: EU

I use Opera 50.x (latest) and Win10.
Steps to Reproduce

  1. Open browser
  2. Clean cache.
  3. Open OCD page.
  4. Double check in private window if needed.

Well, in Opera I couldn’t get it work.
in Chrome, worked for a while and stopped working.

It looks like there are some issues in requests. I got too many errors for this request:

GET 404 ()
hws-connect-scripts.min.js?v=3.0.1:5 Error fetching PHP AJAX data

And another one:
hws-connect.php:19 Uncaught TypeError: Cannot read property ‘initialise’ of undefined
at hws-connect.php:19

Maybe this is a cause.

After pressing Player PDA on the Player Info page, scrolling starts working.

Hey and thanks for the detailed report!

This is still a cache issue on your side. I can’t reproduce this on any browser available.
However I pushed a slight fix for the left sidebar. Please try again by pressing couple of times

CTRL + R while logged in to HWS Connect.

The errors you got fetching the script should be gone aswell then

1 Like

And cleaned the cache, and restarted the browser after cleaning the cache, but scrolling the pages so well and does not work. this should not be.

Very strange… I try to force a new header verify for browsers but did you try some other browsers as well?

ctrl + shift + r as well

Google Chrome, Firefox - on both browsers the result is the same, scrolling does not work. ctrl + shift + r did not give any results.

On the HWS Connect home page, scrolling works, but as I select the server, it stops working.

kind of could reproduce it… very weird. If you are logged in, please click on HWS Skill Tree, or on the Player Stat on the Player PDA button… then it should work

1 Like

I am also having this same issue. It worked when you first launched 3.0 but hasn’t since then. Done all the reloading stuff as well

Well, Rex, you have seen my steps. The cache cleaning in the top. :slight_smile:
And just for the record: I didn’t use Chrome for HWS before this test.
In comments below I see you got some success in reproducing!

Anyway, successes to you, guys, in bug-fixes!

Heh! New software = new bugs. :smiley: Classic! :slight_smile:

And yeah, many thanks for your efforts to making Connect for useful and attractive! :slight_smile:

1 Like

I just checked it in Opera… It woks. :slight_smile:

1 Like

I hope it sorts its out after a while because it seems almost random.

I could reproduce it on Firefox version 57.
But as soon as I opened any modal window it worked again… not even a script error or so.
Very weird. I will fix some other bugs I found already and see if I can find the root cause.

Glad to hear it works for a lot of people now.

Thanks for the kind words. Relieved all my hard work and sleepless hours on my birthday was worth it :slight_smile:

1 Like

Yes, after clicking on HWS Skill Tree or HWS Connect Daily Loot, the scroll starts working. But when the server changes, history repeats itself. It is when selecting a server that the scroll disappears.
I’m writing through an interpreter, if I’m sorry for mistakes;)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.