Selecting "Game"(Game Options), under the functions tab returns an Exception Message

#1

First, I’d like to say, this is an outstanding tool and the best I have ever seen in a GUI to help manage a dedicated server instance.

When I select the functions tab and select the Game Options next to “Server”, “Tool” - I receive an error. I am not able to access that .yaml file. As a result there are a number of tweaks I would normally do that I can’t on my server.

Imgur

I also notice the game.yaml is all on one line… I don’t know if this is the issue as the other config files have multiple lines.

Imgur

#2

Hey,

thanks. Glad it helps you.

The second picture is actually another file. Its not about the first one.

About the Gameoptions: you might want to check the file: …\SteamLibrary\steamapps\common\Empyrion - Dedicated Server\Saves\Games\SAVEGAME NAME\Gameoptions.yaml

The entry “ForcePvP” in line 15 is unknown to me. Did you set this, or did I miss a yaml update?
If you remove it all should be good again.

#3

Thank you for the response. I don’t recall ever setting an option like that. It is possible that I errored, but normally I don’t modify the .yaml files directly unless it is for the random world scenario generating worlds. The following is what my file looks like. Line 15 doesn’t show anything with the “force pvp” option. Should I remove line 25?

I have no idea why it is taking my image and zooming, however line 25 says FrocePvp: true

#4

I removed from line 15 down, that seemed to work. Then I ran an update for the latest version and now it says I’m missing the dedicated.yaml file and the server now fails to start. Is there a particular process when updates roll out as to not corrupt what is already set up on your tool?

I’m sure it is operator error and can be resolved easily… Thanks again.

Update: I found a back up copy of the dedicated.yaml file in an EAH folder. I was able to mostly restore functionality to the prior world. A couple of weird things are occuring one being miners are depleting ore even though it is not checked on the tool. Strange…

#5

Hey,

oh sorry to hear. Hope everything is ok.
If you use the default dedicated.yaml, yes its overwritten on update. Better rename yours and choose that yaml in the EAH-Config. Then also deselect “Use Dedicated.cmd”

image

You don’t need to change anything. You could just take line 25 out and use the tool again. Or you wait for the tool fix (today) and then edit the config (or edit it manually before that)

#6

Fixed it with this update: