Is Krixus Bugged?

======= NOTICE FOR HELP =======

What happened:
=> Everyone is getting severe lag and is constantly being disconnected in rev-6

Player(s) with issue:
=> Heli_Professor, HoboTruth, MonsterIce, Op4, Shaden

=> NA

Time (cb:time):
=> Every 30 seconds of every day

=> Krixus

Structure Name(s):
=> Unknown

Structure ID(s):
=> Unknown

How can we help you now:
=> Rex, I thought I was the only one having lag/latency/packet loss issues. “IF” I can get to the SG gate and get out of Krixus I don’t have near as many disconnects, but when I’m in Krixus I’m getting d/c’d every 5-30 seconds. In other words I’m thinking that something in Krixus is buggy.

My solution, if you are willing to do this, is to start us another donar space (with no resources in it until this hypothesis is tested fully) and transfer over each persons stuff one at a time and let us sort out which structure, or vessel, is giving us such a hard time. In other words, transfer over Hobo’s stuff, we test it, then Op4’s stuff, we test it, until we find what does it or find out that it’s Krixus space that’s doing it and nothing that we’ve spawned in.

We thought also thought it might be the asteroids in Krixus, because I was getting these latency lag issues, BEFORE everyone came over and started plopping their bases/ships down in the play field. I really don’t know how else to troubleshoot our problems here in Krixus. Some of the other complaints is that SVs when undocked will have parts of the CV attached to them drastically increasing the SV class size count (i.e. “floating blocks”).

A secondary solution which is currently in progress is that we go around to ALL of our BPs and make sure we don’t have any old blocks from previously saved blueprints. We are thinking that maybe some of our older BPs have a block(s) that’s out dated.

I tried to do a “tracert” in the windows command console to see where I am losing packets; however, I do not have the NA server IP address, so I could not perform that test. What are your thoughts on the whole situation? Do you have any other suggestions?

Many Thanks,

Several of us have helped Heli trouble shoot the problem and we have had no luck in hunting down a resolution. We’ve noticed that the issues we have in Krixus seem to disappear once we get out of that space. Now the only thing I have issues with is the ping spikes when Heli is in the Krixus playfield, but the lag goes away once we are in another playfield (with more people in that area). So is the playfield bugged? A structure bugged? Or is it a packet loss issue with Heli’s connection? I think we should do a tracert prior to moving further though…


Hello @Heli_Professor and @Op4

Krixus exist since the 12th February. Nothing major changed and the playfield is not corrupt per se.
As I said, I’m chilling here on the Nova Station for some minutes now and get no disconnect or other issue.
I’m a bit lost if I can’t reproduce your issues and I guess others can play fine too if I check the playfield log.

@Heli_Professor it seems something is not well with your location / connection. But as you said, you tried already a lot of things… don’t know…

So who from WAS has this issue and how often?

I can remove the Nova Station, I can remove the Asteroids and the POIs. Sure. But well, it works for me already at the moment…

So what should I remove first for your tests?

My very strong feeling is telling me, that you have a weak Computer @Heli_Professor ?

Checking the logs I see you warp in Krixus and crash.
That is 99,999% because your Computer can’t handle the DSL structures spawning in all one by one

So what you guys should do to help @Heli_Professor is to spread out much more. Don’t camp too many structures in one place.

The other thing I can do to at least give @Heli_Professor a chance to settle on Krixus is to move the Supergate about 10000 meters away from the ring.

Let me know when I should proceed with all of this.

Not sure if it’s related, yesterday I was getting extreme lag trying to do the professor void mission at the black hole miner and was getting extreme lag. Enough to where I would spawn in my CV and immediately die about 15 times as it thought I was still next to the Zirax at the top. Now this may seem off topic, but bear with me for a second.

Is it possible that the DSL is not working properly? My issue yesterday was Empyrion was taking almost all of my RAM, only after completely shutting down Empyrion and getting back in allowed me to continue l. And to add to that I only visited 4 different playfields when this occurred, nobody was anywhere near the black hole miner on ECC,but the memory usage was once again through the roof.

Hi Rex, thanks for lookin’ into this for us, not sure if this is relevant but on top of having all the same problems as Heli, once I logged off in frustration, I started getting the EAC warning when trying to log back on the server. I had to clear my cache and reinstall EAC in order to get back on. Once back on the problem was gone for maybe 30mins. I left and came back in and immediately started getting playfield server disconnect warnings as well as CVDM event warnings while in there.

Hmm I’m not sure really.
Because all of that is not happening for me :frowning: Too bad.

DSL are a main issue for disconnects in such high crowded areas but in your case… don’t think it was DSL. Just the game at its best I guess.

The only change I made ~1 month ago is to change that from 180 to 120

  TimeoutBootingPfServer: 120
  HeartbeatServer: 120
  HeartbeatClient: 120

I’ll set it to 180 with the next server restart again as a test.

As you can see in the forum, EAC is currently the issue for too many.
I already Skyped with the Eleon Dev about it even.

He said EAC is sending a “ping” package over the network every 90 seconds. If EAC does not get an “OK” back for that player from the Dedicated Server, it is blocking the authentification and the player gets kicked / can’t login anymore for awhile.

As bad as it sounds: it is an issue of the players in combination with the surrounding of them.
You see hundreds of players can login and play fine but they are not in your area which might be an issue too.

We already pushed the CPU affinity of the server towards the dedicated.exe but we can’t boost the communication of EAC and the dedi.exe.

TL;DR: we absolutely can’t do anything about it but only blame the bad performance of the game in Multiplayer, which is not ready for “so many” players in 2019.

There are some experiments we can do, like decreasing the range of DSL, so you don’t load tons of structures in a wide range.
But, as always, this opens up exploits in PvP for some sneaky snakes…

Can you send Heli the server IP to do the tracert and test the packet loss? Or is that a non issue?

The port is visible here:

the IP is visible in your Cache folder.

  1. When I opened up my windows command and typed in “tracert” it showed an error. I’m usued to seeing all numbers as an IP address. This is the first time I’ve ever seen an IP with letters.

  2. I will ask everybody if they want to spread out a little and get back to you with new coords. for each person respective future home location. As far as moving the gate, big negative! LoL it’s already 8km to drive from gate to station now.

  3. If you see the above photo and notice the spike, or rise, in linear data. That is me turning on Empyrion Galactic and logging into the HWS NA Server. I did this so you can see what my computer is doing idle and then what it’s doing when I log into the server. It doesn’t appear that I’m struggling with any parameters there.

I said you get the port from that page, not the IP. The IP is a static number, not an DNS.
I don’t want to post the IP in the public because of bot crawlers.

As I said: go in your Cache folder to grab the IP.

@Naithium One thing I’ve learned in all this trouble shooting when I have the EAC issue is to do this:

  1. Task Manager > Close anything to do with steam and/or Empyrion
  2. Open up File Explore and go my game.exe folder
    ( c: > program Files (x86) > steam > steamapps > common > Empyrion Galactic )
  3. Right Click on the “EmpyrionLauncher” which is the .exe file and select “Troubleshoot compatibility”

After running through the prompts there the game would be started thru that process and for whatever reason I wouldn’t get the EAC kicked message/error and I would be able to play. It’s a real PIA, but I literally have to do this process about 1-15 each and every hour I try to play this game for the past week or so. Hope this helps

1 Like

That sounds not good about DSL then.

The Supergate has a 3km² random exit. So you might jump fully in your DSL Nova Station.

That is totally normal for Empyrion. Sad, but normal.

Rexx, I got the IP for him, and there is 0% packet loss.

Packets: Sent = 20, Received = 20, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:
Minimum = 39ms, Maximum = 53ms, Average = 44ms

Yes, as I thought. That is not the issue.
As I explained. The issue is the connection between Unity / Game Dedicated Server <> EAC Server.
That seems the culprit we have 0 options to influence it. :frowning:

Yea, I agree Rexx

@RexXxuS Hey FYI I’ve just tried another test to troubleshoot one more thing. I’ve joined just a random server on the list open to the public and I played for about 15 minutes or so with no problems. I didn’t get disconnected and I didn’t have a problem opening menus etc. Furthermore, I’d like to say that I couldn’t join the NA HWS server, because of the EAC kick message, but I was able to join another server right away. I thought EAC was a steam in general thing. I was dumbfounded by the fact that EAC wouldn’t let me join the HWS server, but it would let me join another server. Don’t take this the wrong way, I’m just trying to provide as much feedback from all the troubleshooting as I can so hopefully someone smarter than me can help me figure this out. I could try to get over to EU and see if I have the same thing?

Tried the same thing. Can access other public servers and Eleon’s official server but the EAC kick message only happens with HWS NA. If I can get on and make it out of Krixus, I will also try on EU.