Nitrado server setup

#1

Hi Guys. i would love to get this running on my server but i cant seem to get the full or lite version to work.
can you give me a walk through of what the settings would be for a nitrado server.

Ryan

1 Like
Admin helper
#2

its a bit tricky.

you need to use the lite version as you dont get RDP access to your server to install the full version – i know, bummer.

Most likely youre getting an error telling you to connect to telnet first, right?

i cant say i know the ‘right’ way to do this – but i got it connected by editing the config file to update my telnet port (it seems hard coded even though there’s a field for it.) i couldnt seem to make nitrado config work via the gui at all…

the telnet server is your game server with specified port in the game server settings; dont forget to enable telnet. you will also need to note the telnet password and update EAHL with this info.


after this you should be able to connect and dork around a bit until Jascha gets around to ya. I’ll be following :wink:

Disclaimer: I seem to have issues with it encrypting my telnet password and ultimately causing it to fail authentication; so this could require some frequent updating of the telnet password (like is said, prob not the ‘right’ way to do it) :slight_smile:

  • Hops
1 Like
Nitrado Assistance
I need to know what I used name to put in FTP User in EAH
#3

Dont put the password plain into the xml… do it over the tool (or in case of telnet, let the tool read your dedicated.yaml from server). The Password is encrypted in xml so he will try to decrpyt your pw… that will not work :wink:

#4

yeah i noticed it only worked once, then encrypted it… but it always failed if i used the gui. :frowning:

id be willing to help put together a nitrado how to guide if i could nail it down. :slight_smile: it does happen to be the suggested server by the devs (for some reason). i have a small test server there.

I’ll give it another crack.

  • Hops
#5

thanks for replying. I have changed the the telnet port in the xml but i still cant get it to work.

Cheers Ryan

#6

Please dont change something in the xml . If you have to change it there, then something is not installed correct.
First you need a working FTP-Connection to the server, only then he can download the dedi.yaml and get its telnet infos.

1 Like
Nitrado Assistance
#7

progress for nitrado!

enter your FTP server on server config tab,

for Nitrado it appears you need to enable FTP active AND FTP Old Way

enter the rest of the reqauired account info, put your GAME SERVER IP into the Overwrite telnet IP box!
then click refresh FTP

you should now see your telnet window come alive

i did however run into this error

my game.dat is one folder deerper under Game_0.

also, AM doesnt appear able to be enabled at this time.

much farther! no XML editing!

1 Like
#8

Thanks a lot for the details.
hm can you edit your dedicated.yaml and edit the “GameName” parameter. Just enter ther the name “Game_0” and it should work:

GameName: Game_0   # Determines name of the save game
#9

Telnet is not the problem. Can you check if players are listed in the left list? Or do you have a check box for online player?

#10

made the changes above and also tested - i CAN See my players in EAHL on the list on the left!

  • Hops
#11

But then you have no problems or? Since ftp and telnet seeme to work.
Or do you still have the game.dat/dedicated download error?
If oyu still get an error, please check if you have rights to that files and if the files are visible there. But that would all make no sence if he could download the player… which he needs the dedicated.yaml for to find them in the first place.

1 Like
#12

As of this mornings restart, no errors at all! :slight_smile:
Hopefully this will help the OP also set up his Nitrado server as well.

#14

Can you FTP to that folder using the same credentials? Do you get in no problem with otehr FTP client with the same directory set as home?

if so, are you checking BOTH FTP boxes (Use Old way, FTP Active)

#15

Can you past e a SS of your Config page and your FTP page? You can obscure usernames if you like…

#16

replied via PM

#17

okay ftp refreh ->succcessful
start telnet .>fail
bei pUwRvEYSRqDJNxpjpNnJuSUshfux.‬‍‏​‌‫‍‫‮‍‏​​‍​‮‏‬‭‮‬​‫‌‬‮()
bei TelnetSocket.DoConnect(String Host, Int32 Port)
bei System.Net.Sockets.TcpClient…ctor(String hostname, Int32 port)
System.Net.Sockets.SocketException (0x80004005): Ein Socketvorgang bezog sich auf ein nicht verfügbares Netzwerk 0.0.81.68:20804
how i can change the telnet ip? ^^

and where is my german support? ^^

#18

Sorry dont speak german… But if my english help is ok, Are you putting the telnet IP into the “Override Telnet IP” in the FTP config Box?

1 Like
EAH Help!
#19

Wie hast du das geschafft?
Wie hops sagt. einfach die richtige Telent IP in das feld “overwrite Telnet IP” eingeben und noch mal versuchen.

2 Likes
#20

ah okay^^
hatte da nur den port drin danke euch :heart:

Thx too u :slight_smile:

#21

I can’t seem to get this working for Nitrado with the experimental branch, I can chat, but that’t it, it does not show the players or the standard info in the telnet window, the power button looking icon is red. it was able to download the dedicated.yaml file, and I do have the overwrite ip in the port.

any suggestions?